Android P deve bloquear funcionamento de apps antigos

O Android P deve bloquear aplicativos antigos do sistema móvel do Google. De acordo com o Android Police, a versão para desenvolvedores da nova plataforma já exibe mensagens de aviso para softwares feitos para Android 4.1 ou anterior, o que indica que o Google planeja limitar o uso desses apps.

O Google já confirmou que vai bloquear apps que não usem APIs recentes do sistema móvel, e agora começou a colocar o plano em prática. No Android P, apps desenvolvidos para a versão 4.1 Jelly Bean (lançada em 2012) ou anterior do sistema exibem uma mensagem de alerta de que suas funcionalidades podem ser limitadas.

Para os aplicativos funcionarem, eles precisarão ser adaptados para as novas versões do Android. A ideia é melhorar a usabilidade do sistema e garantir segurança dos usuários. Apps antigos podem estar vulneráveis a falhas antigas que foram consertadas em versões mais recentes do sistema, além de não serem otimizados para smartphones modernos e poderem prejudicar o desempenho deles.

Por enquanto, o Android P não bloqueia completamente o aplicativo, só exibe um alerta dizendo que ele foi feito para versões antigas do sistema. Não está claro se o Google vai de fato bloquear os apps quando a versão final for lançada, ou se vai manter apenas os avisos por enquanto.

Compras na Internet? Para aproveitar as melhores ofertas, baixe a nova extensão do Olhar Digital. Além da garantia do melhor preço, você ainda ganha descontos em várias lojas. Clique aqui para instalar.




RECOMENDADO PARA VOCÊ