EnglishPortugueseSpanish

De acordo com o jornal NZ Herald, a Apple está informando seus usuários de iPhones 5S ou iPhone 4S sobre a urgência em atualizar seus dispositivos, sob o risco de perder várias funções importantes no aparelho como GPS, e-mail, iCloud, App Store e outros serviços. O culpado por essa falha técnica é o GPS Rollover, que ocorre uma vez a cada aproximadamente 20 anos.

O problema se dá pela maneira em que a tecnologia GPS acompanha o tempo, uma vez que o sistema conta semanas usando códigos binários e por isso só pode contar até 1024, o que corresponde a 19 anos e dez meses, resetando logo em seguida. Assim os programas que dependem do GPS para apresentar data e hora corretas, mas que não foram codificados para dar conta da rolagem, podem ser enganados e exibir uma data de 20 ou 40 anos atrás ou até mesmo parar de funcionar.

publicidade

O Rollover começou a acontecer em alguns sistemas em abril deste ano, quando alguns componentes de GPS utilizados pelo conglomerado americano Honeywell sofreram interferências, entre eles aviões da Boeing e balões meteorológicos do Bureau of Meteorology.

Os dispositivos da Apple devem começar a falhar na meia-noite do próximo domingo (03) e precisam ser atualizados antes desta data, para evitar uma grande perda de backup e de restauração de processo usando um computador separado.

Os usuários do iPhone 5 devem atualizar para o iOS 10.3.4 e, no caso do iPhone 4S, para o iOS 9.3.6. Para checar sua atual versão de software você pode ir para ‘Geral’ e depois em ‘Sobre’. No caso do seu telefone estar programado para atualização automática, provavelmente isso não será um problema para você, apesar de valer a pena checar duas vezes o número da atualização.

O GPS rollover irá desabilitar o iPad até a 4ª geração.