Vulnerabilidade no HP Device Manager permite que invasores controlem sistema

Outros dois problemas encontrados incluem exposição de contas gerenciadas pelo dispositivo e acesso não autorizado ao aparelho

Luiz Nogueira 06/10/2020 14h35
Notebook HP
A A A

Para alertar seus usuários, a HP lançou um comunicado de segurança que detalhou três vulnerabilidades críticas no HP Device Manager, usado por administradores para gerenciar remotamente dispositivos que usam um servidor central para várias tarefas. A mais grave das falhas pode levar ao controle total do sistema.


Descobertas originalmente pelo pesquisador de segurança Nick Bloor, as vulnerabilidades permitem que invasores ganhem privilégios de sistema remotamente em dispositivos que executam versões do Device Manager. O impacto potencial desses problemas também inclui acesso remoto não autorizado e recursos de elevação de privilégio.

No comunicado liberado pela empresa, as vulnerabilidades foram identificadas como CVE-2020-6925, CVE-2020-6926 e CVE-2020-6927. Além disso, a companhia liberou uma breve descrição do que cada uma causa.

Reprodução

Três vulnerabilidades foram descobertas no HP Device Manager. Foto: Jozsef Bagota/ Shutterstock

A primeira delas, CVE-2020-6925, afeta todas as versões do Device Manager e expõe contas gerenciadas localmente pelo recurso. Isso ocorre devido à implementação de criptografia fraca. Felizmente, o problema não afeta contas que foram autenticadas pelo Active Directory.

A CVE-2020-6926 afeta todas as versões do Device Manager e permite que cibercriminosos obtenham acesso não autorizado aos aparelhos. Por fim, a CVE-2020-6927 oferece aos invasores opções para aumentar privilégios para controlar o sistema.

Possíveis soluções

Para resolver a última das vulnerabilidades, que podem elevar o privilégio de invasores, os usuários podem baixar a versão mais recente do HP Device Manager, que é identificada pelo número 5.0.4.
No entanto, para os outros dois problemas, a HP ainda não publicou updates de segurança para solucioná-los. Apesar disso, a empresa forneceu algumas soluções temporárias.

A primeira delas é limitar o acesso de entrada às portas 1099 e 40002 do gerenciador de dispositivos apenas para IPs confiáveis ou host local. Também é possível remover a conta "dm_postgres" do banco de dados Postgres.

Por fim, na configuração do firewall do Windows, basta criar uma regra de entrada para configurar a porta de escuta PostgreSQL (40006) apenas para acesso local. Essas dicas podem ajudar a proteger os dispositivos enquanto o update com a correção não é lançado. 

Via: Bleeping Computer

Segurança HP vulnerabilidade falha de segurança computador
Compras na Internet? Para aproveitar as melhores ofertas, baixe a nova extensão do Olhar Digital. Além da garantia do melhor preço, você ainda ganha descontos em várias lojas. Clique aqui para instalar.

Recomendados pra você